Browse Source

configure: qemu-ga is only needed with softmmu targets

Remove it from the list of tools if --disable-system
and --disable-tools are used as we don't need it for
linux-user targets.

Suggested-by: Paolo Bonzini <pbonzini@redhat.com>
[lv: I also disable it with disable-tools, not only with disable-system]
Signed-off-by: Laurent Vivier <lvivier@redhat.com>
Message-Id: <20190401141222.30034-4-lvivier@redhat.com>
tags/v4.1.0-rc0
Laurent Vivier 8 months ago
parent
commit
a512590595
1 changed files with 3 additions and 1 deletions
  1. +3
    -1
      configure

+ 3
- 1
configure View File

@@ -6079,7 +6079,9 @@ fi
# Probe for guest agent support/options

if [ "$guest_agent" != "no" ]; then
if [ "$linux" = "yes" -o "$bsd" = "yes" -o "$solaris" = "yes" -o "$mingw32" = "yes" ] ; then
if [ "$softmmu" = no -a "$want_tools" = no ] ; then
guest_agent=no
elif [ "$linux" = "yes" -o "$bsd" = "yes" -o "$solaris" = "yes" -o "$mingw32" = "yes" ] ; then
tools="qemu-ga $tools"
guest_agent=yes
elif [ "$guest_agent" != yes ]; then

Loading…
Cancel
Save